SUNIC RDAP сервіс для доменів.

Сервіс RDAP надає актуальну інформацію про домени, неймсервери, реєстраторів, реєстрантів та контакти.
RDAP сервіс SUNIC підтримує наступні домени:
  • IN.UA
  • OD.UA
  • ODESA.UA
  • ODESSA.UA
  • MK.UA
  • MYKOLAIV.UA
  • NIKOLAEV.UA
Для отримання прихованої інформації про об'єкти, спонсором яких ви є (у термінах EPP), запит повинен бути авторизованим.
Параметри авторизації відповідають параметрам EPP сервера SUNIC.
Сервіс підтримує базову аутентифікацію HTTP.

Приклади запитів до RDAP сервіса щодо інформації про:
домен: https://rdap.sunic.ua/domain/domain.in.ua
неймсервер: https://rdap.sunic.ua/nameserver/ns.domain.in.ua
реєстратора: https://rdap.sunic.ua/entity/ua.ukraine
реєстранта / контакт: https://rdap.sunic.ua/entity/cid_string

Приклади запитів до RDAP сервіса щодо пошуку об'єктів:
домени: https://rdap.sunic.ua/domains?name=dom*.in.ua
https://rdap.sunic.ua/domains?nsLdhName=ns.dom*.in.ua
https://rdap.sunic.ua/domains?nsIp=195.80.117.50
неймсервери: https://rdap.sunic.ua/nameservers?name=ns.dom*.in.ua
https://rdap.sunic.ua/nameservers?ip=195.80.117.50
реєстратори: https://rdap.sunic.ua/entities?fn=Хостінг%20Укр*
https://rdap.sunic.ua/entities?handle=ua.ukr*
реєстранти / контакти: https://rdap.sunic.ua/entities?fn=Коцюба*
https://rdap.sunic.ua/entities?handle=cid_str*

Кількість знайдених об'єктів у відповіді сервера на запит пошуку не перевищує встановленного обмеження. На данний час обмеження - три об'єкти.
Статус коди негативних відповідей, що повертаються сервером на запити:
400 - недійсний запит
404 - об'єкти, що запитуються, не знайдені
429 - перевищено ліміт кількості запитів з однієї IP адреси в одиницю часу
500 - помилка сервера
RFC
  • RFC7480 - HTTP Usage in the Registration Data Access Protocol (RDAP)
  • RFC7481 - Security Services for the Registration Data Access Protocol (RDAP)
  • RFC7482 - Registration Data Access Protocol (RDAP) Query Format
  • RFC7483 - JSON Responses for the Registration Data Access Protocol (RDAP)
  • RFC8056 - Extensible Provisioning Protocol (EPP) and Registration Data Access Protocol (RDAP) Status Mapping
У разі виникнення запитань чи помилок звертайтесь за адресою support@sunic.ua